Installing Reduceme



First, verify that the following files are available (here, perhaps?):

cfitsio2420.tar.gz
pgplot-5.2.0-9ds.i386.rpm
pgplot-devel-5.2.0-9ds.i386.rpm
reduceme_v3_3.tar.gz

And the directory lib that has a bunch of .a files. The important one is libX11.a, but I figured that we might as well copy them all.
  1. I've been starting with cfitsio.
    1. Unpack the tar file
    2. run configure
    3. run make
    4. copy to /usr/lib/cfitsio
  2. Then do pgplot
    1. Install both pgplot and pgplot-devel rpm's
  3. Copy the .a files from lib to /usr/X11R6/lib/
  4. Finally reduceme
    1. Unpack the tar file to /usr/local/reduceme
    2. Edit the file ./red/redlib.inc to have 2100 for both NSMAX and NCMAX
    3. Change to previous directory
    4. Make sure that the environment variables PGPLOT_DIR and FITSIO_DIR are set to the right directories
    5. Run ./create_reduceme f77 cc /usr/X11R6/lib

This should do it.